必要システム構成

DokuWiki を実行するには、次が必要です。

  1. PHP を実行できるウェブサーバ
    • Apache を推奨しますが、他のサーバでも正常に動作するとの報告を多数受けています
  2. PHP 4.3.x 。セキュリティー上の問題 のため、PHP 4.3.10 以降を推奨します 1)
    • PHP タグの短縮型 を有効にする必要はなくなりました 2)
    • 必須ではありませんが、PHP の GD 拡張モジュール は、libGD 2 (グラフィックライブラリ) を使うものを推奨します
    • DokuWiki は、PHP の セーフモード でも動作します。ホストの設定に応じて、safemodehack オプションを使用する必要があります
    • DokuWiki は、PHP の register_globals オプションを OFF にして動作するように設計されています
    • 新規ユーザ登録に e メールでの確認を必要にする場合は、PHP がメールを送信できるよう正しく設定する必要があります
  3. ちゃんとしたウェブブラウザ (互換性リスト を参照してください))

プラグインスペルチェッカ などの機能を追加するには、上記以外の構成が必要となる場合があります。

翻訳について

english version: 2006-08-11 10:41.

このページを作成・変更した方は、次にメールアドレスを追記してください。 Add your email here if you created translated or modified whole or part of this page.

1) RedHat Enterprise Linux は、これらのセキュリティーフィックスを RHEL V3 では php-4.3.2-30、RHEL V4 では php-4.3.9-3.12 と言った古いバージョンに バックポート しています
2) もし、問題が発生する場合は、 バグ報告 してください